Discussion:
[digikam] [Bug 386522] New: video encoder in digicam (windows 10)
(too old to reply)
Martin Seidel
2017-11-04 13:27:15 UTC
Permalink
https://bugs.kde.org/show_bug.cgi?id=386522

Bug ID: 386522
Summary: video encoder in digicam (windows 10)
Product: digikam
Version: 5.7.0
Platform: MS Windows
OS: MS Windows
Status: UNCONFIRMED
Severity: wishlist
Priority: NOR
Component: Albums-Engine
Assignee: digikam-bugs-***@kde.org
Reporter: ***@gmx.de
Target Milestone: ---

Hello, first of all I would like to emphasize that I am amazed at how well
digikam works under windows 10, although it is actually only intended for
Linux!

My question: is it possible to choose the same video encoder, the windows used
synonymous? That would be good because the videos under digicam in the slide
show unfortunately something jerky, which is not the case in the photo tool of
windows.

Many Thanks!

Best regards,
Martin
--
You are receiving this mail because:
You are watching all bug changes.
b***@kde.org
2017-11-04 15:53:54 UTC
Permalink
https://bugs.kde.org/show_bug.cgi?id=386522

***@gmail.com changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |***@gmail.com
Component|Albums-Engine |Preview-Video

--- Comment #1 from ***@gmail.com ---
You want mean video "decoder", right ?

Gilles Caulier
--
You are receiving this mail because:
You are watching all bug changes.
Martin Seidel
2017-11-04 21:03:53 UTC
Permalink
https://bugs.kde.org/show_bug.cgi?id=386522

--- Comment #2 from Martin Seidel <***@gmx.de> ---
Yes I meant decoder!
--
You are receiving this mail because:
You are watching all bug changes.
b***@kde.org
2017-11-04 22:23:55 UTC
Permalink
https://bugs.kde.org/show_bug.cgi?id=386522

--- Comment #3 from ***@gmail.com ---
What's the problem with video playing exactly ? Whitch file format do you want
to play ?

Gilles Caulier
--
You are receiving this mail because:
You are watching all bug changes.
Martin Seidel
2017-11-04 23:33:45 UTC
Permalink
https://bugs.kde.org/show_bug.cgi?id=386522

--- Comment #4 from Martin Seidel <***@gmx.de> ---
It is just a performance Problem, the Video is a 4k mp4 file. It is The same
with vlc player on that PC. Only media player classic and Windows photo can
play without judder.
--
You are receiving this mail because:
You are watching all bug changes.
Christoph Feck
2017-11-08 16:07:56 UTC
Permalink
https://bugs.kde.org/show_bug.cgi?id=386522

--- Comment #5 from Christoph Feck <***@kde.org> ---
4K videos probably require hardware acceleration. I think QtAV has support for
VA-API and/or VDPAU, but these probably have to be enabled in client
applications.
--
You are receiving this mail because:
You are watching all bug changes.
Christoph Feck
2017-11-08 16:10:59 UTC
Permalink
https://bugs.kde.org/show_bug.cgi?id=386522

--- Comment #6 from Christoph Feck <***@kde.org> ---
Oh, this is for Windows.

https://github.com/wang-bin/QtAV/wiki/Hardware-Accelerated-Decoding might give
some hints.
--
You are receiving this mail because:
You are watching all bug changes.
b***@kde.org
2017-11-08 16:15:35 UTC
Permalink
https://bugs.kde.org/show_bug.cgi?id=386522

--- Comment #7 from ***@gmail.com ---
Also the 4K is H265 codec relevant i think, which is not compiled with ffmpeg
through MXE crooss compiler used to build Windows bundle. I'm not sure to 100%

But the point about VLC is interesting as the problem is also reproducible with
this player.

To respond to your question about to use native player instead QtAV. I said no,
because we drop QtMultimedia support in favor of QtAV because we want all in
the bundle and ready to use as well... QtMultimedia require to install native
codecs which increase complexity at application runtime.

Gilles Caulier
--
You are receiving this mail because:
You are watching all bug changes.
b***@kde.org
2018-03-14 08:45:47 UTC
Permalink
https://bugs.kde.org/show_bug.cgi?id=386522

***@gmail.com changed:

What |Removed |Added
----------------------------------------------------------------------------
Summary|video encoder in digicam |video decoder backend in
|(windows 10) |digiKam (windows 10)
--
You are receiving this mail because:
You are watching all bug changes.
Loading...