Discussion:
[digikam] [Bug 396712] New: "Save Search" does not work
Add Reply
Dan Callahan
2018-07-20 21:28:02 UTC
Reply
Permalink
https://bugs.kde.org/show_bug.cgi?id=396712

Bug ID: 396712
Summary: "Save Search" does not work
Product: digikam
Version: unspecified
Platform: Other
OS: Linux
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Searches
Assignee: digikam-bugs-***@kde.org
Reporter: ***@gmail.com
Target Milestone: ---

I am unable to save searches in Digikam 5.9.0, using both the AppImage and
Fedora's package of Digikam.

Steps to Reproduce:

1. Open the "Search" tab in the left panel
2. Enter a search query (e.g., "2012")
3. Enter a name for the search (e.g., "Foo")
4. Press Return or click the save button next to "Save Current Search"

Expected Results:

5. A new saved search named "Foo" appears in search panel.

Actual Results:

5. Nothing happens.
6. The following text appears in the console:

digikam.general: name = "Foo"
digikam.general: no current album, returning

Other Notes:

- Saving searches in the Timeline panel does work.
- This appears to be failing because d->currentAlbum is false-y at
https://cgit.kde.org/digikam.git/tree/utilities/searchwindow/searchtabheader.cpp?h=v5.9.0#n482
- I also see the same problem with the latest pre-release build
(6.0.0-git-20180707T160254)

This feels like it must be some kind of user error, but I can't for the life of
me work out what's going wrong, and there's no visible feedback in the UI to
help discern what the problem is.
--
You are receiving this mail because:
You are watching all bug changes.
Maik Qualmann
2018-07-20 22:03:10 UTC
Reply
Permalink
https://bugs.kde.org/show_bug.cgi?id=396712

Maik Qualmann <***@gmail.com> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|UNCONFIRMED |RESOLVED
Resolution|--- |FIXED
Latest Commit| |https://commits.kde.org/dig
| |ikam/8b06fe8f2d891998a1b0d8
| |da254c822cd2e707bf
Version Fixed In| |6.0.0

--- Comment #1 from Maik Qualmann <***@gmail.com> ---
Git commit 8b06fe8f2d891998a1b0d8da254c822cd2e707bf by Maik Qualmann.
Committed on 20/07/2018 at 22:01.
Pushed by mqualmann into branch 'master'.

set the current search album when the search tab is activated
Because of a change in the start of digiKam that we block the signals of the
tree views,
no current album will be set when starting digikam, because that speeds up the
start
FIXED-IN: 6.0.0

M +2 -1 NEWS
M +1 -0 core/app/views/leftsidebarwidgets.cpp

https://commits.kde.org/digikam/8b06fe8f2d891998a1b0d8da254c822cd2e707bf
--
You are receiving this mail because:
You are watching all bug changes.
Maik Qualmann
2018-07-20 22:26:09 UTC
Reply
Permalink
https://bugs.kde.org/show_bug.cgi?id=396712

Maik Qualmann <***@gmail.com> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |***@gmail.com

--- Comment #2 from Maik Qualmann <***@gmail.com> ---
Note: as workaround for digiKam-5.9.0, select a saved search beforehand.

Maik
--
You are receiving this mail because:
You are watching all bug changes.
Maik Qualmann
2018-12-07 06:50:48 UTC
Reply
Permalink
https://bugs.kde.org/show_bug.cgi?id=396712

Maik Qualmann <***@gmail.com> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |***@videotron.ca

--- Comment #3 from Maik Qualmann <***@gmail.com> ---
*** Bug 401849 has been marked as a duplicate of this bug. ***
--
You are receiving this mail because:
You are watching all bug changes.
Loading...