Discussion:
[Bug 274333] Digikam crashed upon startup
(too old to reply)
Marcel Wiesweg
2011-05-30 20:05:03 UTC
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=274333


Marcel Wiesweg <marcel.wiesweg-***@public.gmane.org> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |cguthrie-***@public.gmane.org,
| |myriam-***@public.gmane.org
Component|general |Pulsesupport
Version|1.9.0 |4.5 (KDE 4.6.2)
Product|digikam |Phonon




--- Comment #1 from Marcel Wiesweg <marcel wiesweg gmx de> 2011-05-30 22:05:01 ---
Crash occurs in Phonon / Pulse Audio backend
--
Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.
Colin Guthrie
2011-05-31 08:08:35 UTC
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=274333





--- Comment #2 from Colin Guthrie <cguthrie mandriva org> 2011-05-31 10:08:34 ---
Can you work out what the assertion was that caused this? Dr Konqui seems to
swallow them up and not actually print them out?

If in doubt, just run digikam manually with the --nocrashhandler and let me
know what the assertion is.
--
Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.
Krisztian Mark Szentes
2011-06-14 21:40:50 UTC
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=274333


Krisztian Mark Szentes <mark-h7+y+***@public.gmane.org> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |mark-h7+y+***@public.gmane.org
--
Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.
Krisztian Mark Szentes
2011-06-14 21:41:20 UTC
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=274333





--- Comment #3 from Krisztian Mark Szentes <mark szentes org> 2011-06-14 23:40:51 ---
Created an attachment (id=61002)
--> (http://bugs.kde.org/attachment.cgi?id=61002)
New crash information added by DrKonqi

digikam (1.9.0) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

This time the crash occurred again. I cannot say when digikam will crash and
when not, so this time I did not start with the --nocrashhandler option. Sorry!

I hope you will see a difference to the other report.

-- Backtrace (Reduced):
#10 0x008537d9 in pa_context_connect () from /usr/lib/libpulse.so.0
#11 0x0050c068 in Phonon::PulseSupport::connectToDaemon (this=0xa863fe0) at
../../phonon/pulsesupport.cpp:904
#12 0x0050cb50 in Phonon::PulseSupport::qt_metacall (this=0xa863fe0,
_c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfa797dc) at
./moc_pulsesupport.cpp:78
[...]
#15 0x01ba94d7 in QSingleShotTimer::timeout (this=0xd01e568) at
.moc/release-shared/qtimer.moc:82
#16 0x01ba958c in QSingleShotTimer::timerEvent (this=0xd01e568) at
kernel/qtimer.cpp:308
--
Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.
Colin Guthrie
2011-06-15 08:18:10 UTC
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=274333





--- Comment #4 from Colin Guthrie <cguthrie mandriva org> 2011-06-15 10:18:08 ---
Hmm, it's going to be really tricky to nail this down :(

When this happens, do you happen to know if PA has restarted itself? (one way
to tell is that if PA has been running since login, the device list in Phonon
config should look nice. e.g. a list of device names (tho' that list may of
course only have one entry in it!). It will be called something like "Internal
Audio....". If it just has a single entry called "PulseAudio", then chances are
it's been restarted.

If PA has been restarted it could indicate that PA has crashed and it's left
over remnants that cause this problem.

It's just strange as I would have thought this problem should have cropped up a
lot more if it was endemic... which is why this is quite strange... :s

I'm not really sure what to suggest next. Perhaps try running "PULSE_LOG=99
pactl stat" after the crash to see if things in general are messed up (tho' I
suspect things will have recovered by then :s).

Like I say it's a tricky one to debug.. :s
--
Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.
b***@kde.org
2018-08-10 12:42:51 UTC
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=274333

***@gmail.com changed:

What |Removed |Added
----------------------------------------------------------------------------
Assignee|digikam-bugs-***@kde.org |***@kde.org
--
You are receiving this mail because:
You are watching all bug changes.
b***@kde.org
2018-08-21 09:00:07 UTC
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=274333

***@gmail.com changed:

What |Removed |Added
----------------------------------------------------------------------------
Assignee|***@kde.org |digikam-bugs-***@kde.org
Version Fixed In| |6.0.0
Resolution|INVALID |FIXED
Component|Pulsesupport |Preview-Video
Version|4.5.0 (KDE 4.6.2) |unspecified
Product|Phonon |digikam
CC| |***@gmail.com

--- Comment #7 from ***@gmail.com ---
Not reproducible since digiKam use QtAv framework + ffmpeg to handle video
files.
--
You are receiving this mail because:
You are watching all bug changes.
Loading...