Discussion:
[Discover] [Bug 397211] New: Discover doesn't properly show flatpak appdata (missing images, description flatpak name)
Add Reply
b***@kde.org
2018-08-06 13:11:05 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=397211

Bug ID: 397211
Summary: Discover doesn't properly show flatpak appdata
(missing images, description flatpak name)
Product: Discover
Version: 5.13.3
Platform: Fedora RPMs
OS: Linux
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: Flatpak Backend
Assignee: ***@kde.org
Reporter: ***@gmail.com
CC: ***@redhat.com
Target Milestone: ---

Created attachment 114326
--> https://bugs.kde.org/attachment.cgi?id=114326&action=edit
No pictures displayed, no description on krita flatpak

When viewing flatpaks through discover, no images previews are being displayed
and some keep their flatpak names (e.g. org.gnome.Lollypop.desktop).

Steps to reproduce:
- Open discover
- Click on a flatpak

Additional information: At startup, Discovers asks to check whether Appstream
is properly set up.
--
You are receiving this mail because:
You are watching all bug changes.
Nate Graham
2018-08-09 20:25:57 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=397211

Nate Graham <***@kde.org> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|UNCONFIRMED |NEEDSINFO
CC| |***@kde.org
Resolution|--- |WAITINGFORINFO

--- Comment #1 from Nate Graham <***@kde.org> ---
"org.gnome.Lollypop.desktop" is actually a Flathub bug.

What happens if you remove the flathub repo and re-add it?
--
You are receiving this mail because:
You are watching all bug changes.
b***@kde.org
2018-08-10 13:50:37 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=397211

--- Comment #2 from ***@gmail.com ---
I've got the same issues after re-adding the repo! However I've gotten a huge
amount of flatpak updates afterwards. Strange indeed.
--
You are receiving this mail because:
You are watching all bug changes.
Nate Graham
2018-08-10 13:52:43 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=397211

Nate Graham <***@kde.org> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|NEEDSINFO |UNCONFIRMED
Resolution|WAITINGFORINFO |---

--- Comment #3 from Nate Graham <***@kde.org> ---
Strange indeed.
--
You are receiving this mail because:
You are watching all bug changes.
b***@kde.org
2018-08-10 14:00:11 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=397211

--- Comment #4 from ***@gmail.com ---
Well the updates fail, actually. But the terminal output changed.

Maybe this will help.

***@metal:~% plasma-discover
QQmlComponent: Created graphical object was not placed in the graphics scene.

** (process:25456): WARNING **: 15:58:12.198: Found icon of unknown type,
skipping it: unknown
Could not open the AppStream metadata pool "Metadata files have errors:
/usr/share/app-info/xmls/google-chrome.xml"
invalid kns backend! "/etc/xdg/servicemenu.knsrc" because: "Config group not
found! Check your KNS3 installation."
invalid kns backend! "/etc/xdg/ksysguard.knsrc" because: "Config group not
found! Check your KNS3 installation."
Discarding invalid backend "servicemenu.knsrc"
Discarding invalid backend "ksysguard.knsrc"
Couldn't get latest commit for com.discordapp.Discord
Couldn't get latest commit for org.gimp.GIMP
Couldn't get latest commit for org.kde.krita
Couldn't get latest commit for org.qbittorrent.qBittorrent
Couldn't get latest commit for org.videolan.VLC
Couldn't get latest commit for org.freedesktop.Platform.Compat32
Couldn't get latest commit for org.freedesktop.Platform.Icontheme.Adwaita
Couldn't get latest commit for org.freedesktop.Platform.ffmpeg
Couldn't get latest commit for org.freedesktop.Platform
Couldn't get latest commit for org.gnome.Platform.Locale
Couldn't get latest commit for org.gnome.Platform
Couldn't get latest commit for org.gtk.Gtk3theme.Breeze-Dark
Couldn't get latest commit for org.gtk.Gtk3theme.Breeze
Couldn't get latest commit for org.kde.KStyle.Adwaita
Couldn't get latest commit for org.kde.KStyle.Adwaita
Couldn't get latest commit for org.kde.Platform.Locale
Couldn't get latest commit for org.kde.Platform
Couldn't get latest commit for org.kde.krita.Locale
Couldn't get latest commit for org.videolan.VLC.Locale

Flatpak updates from flathub work on my other PC, so I'd say it is likely that
this isn't a flathub bug.
--
You are receiving this mail because:
You are watching all bug changes.
Omar
2018-08-15 12:58:00 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=397211

Omar <***@gmail.com> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |***@gmail.com

--- Comment #5 from Omar <***@gmail.com> ---
Created attachment 114445
--> https://bugs.kde.org/attachment.cgi?id=114445&action=edit
Discover showing data correctly
--
You are receiving this mail because:
You are watching all bug changes.
Omar
2018-08-15 13:01:05 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=397211

--- Comment #6 from Omar <***@gmail.com> ---
Could it be something related to Flatpak/Discover specifically on Fedora,
because everything works fine for me on KDE Neon, Discover v5.13.4

https://bugs.kde.org/attachment.cgi?id=114445
--
You are receiving this mail because:
You are watching all bug changes.
Loading...