Discussion:
[elisa] [Bug 390380] New: Elisa consumes higher CPU than Amarok does when playing the same mp3 file
(too old to reply)
CnZhx
2018-02-13 15:33:32 UTC
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390380

Bug ID: 390380
Summary: Elisa consumes higher CPU than Amarok does when
playing the same mp3 file
Product: elisa
Version: 0.0.81
Platform: openSUSE RPMs
OS: Linux
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: general
Assignee: ***@yahoo.fr
Reporter: ***@cnzhx.net
Target Milestone: ---

I am very glad that Elisa is not in the OSS repo of openSUSE Tumbleweed. Thank
you all for the good work.

I am not sure whether this worth a bug report. But I notice that when playing
the same mp3 file, Elisa takes 8-12% CPU usage while Amarok takes around 2% in
my laptop.
--
You are receiving this mail because:
You are watching all bug changes.
Nate Graham
2018-02-13 22:43:20 UTC
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390380

Nate Graham <***@zoho.com> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |***@zoho.com
--
You are receiving this mail because:
You are watching all bug changes.
Michael D
2018-03-02 16:53:57 UTC
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390380

Michael D <***@gmail.com> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |***@gmail.com

--- Comment #1 from Michael D <***@gmail.com> ---
Same problem here except that I am seeing over 20% with elisa and over 20% with
kwin_wayland and kwin_x11. If I minimize the window while playing, cpu usage
massively drops off in x11 to 2-3%, but not in wayland.
--
You are receiving this mail because:
You are watching all bug changes.
Matthieu Gallien
2018-03-20 07:13:26 UTC
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390380

Matthieu Gallien <***@yahoo.fr> changed:

What |Removed |Added
----------------------------------------------------------------------------
Ever confirmed|0 |1
Status|UNCONFIRMED |CONFIRMED

--- Comment #2 from Matthieu Gallien <***@yahoo.fr> ---
As far as I can say, there seems to be a visible usage coming from the playing
indicator (the play icon with animated opacity).

I am looking at that and hope to find a satisfying solution before the 0.1
release.
--
You are receiving this mail because:
You are watching all bug changes.
Matthieu Gallien
2018-03-26 19:33:36 UTC
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390380

Matthieu Gallien <***@yahoo.fr> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|CONFIRMED |RESOLVED
Resolution|--- |FIXED

--- Comment #3 from Matthieu Gallien <***@yahoo.fr> ---
I have pushed commit:

commit 478cd6ee15b1195592a143d76d325c1091e6d08a (origin/0.1, 0.1)
Author: Matthieu Gallien <***@yahoo.fr>
Date: Sun Mar 25 20:38:12 2018 +0200

no longer have a play icon bouncing but use an icon like the plasma taskbar

Summary:
no longer have a play icon bouncing but use an icon like the plasma taskbar

We no longer have an animation running when music is playing. We should no
longer have excess cpu usage.

We now use a common icon to indicate the playing track (plasma task bar,
firefox tabs, ...)

Test Plan: cpu usage should be lower when playing music

Reviewers: #elisa, #vdg, astippich

Reviewed By: #elisa, astippich

Subscribers: romangg, astippich

Differential Revision: https://phabricator.kde.org/D11667


That should fix most visible issues related to extra cpu usage.

Two things have changed:

* the busy indicator when not running may have caused constant refresh of the
application window generating cpu usage for elisa and the window manager.

* the play indicator is no longer animated. This should avoid having refresh of
the application window when playing music. This is especially important of you
do not see the animation.
--
You are receiving this mail because:
You are watching all bug changes.
CnZhx
2018-03-26 19:52:18 UTC
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390380

--- Comment #4 from CnZhx <***@cnzhx.net> ---
Hi @Matthieu , thanks for the fix.

But I want to ask that is this related to bug #356479
(https://bugs.kde.org/show_bug.cgi?id=356479)? It seems the bug of high cpu
with animated icon has already been fixed. Do you know why does it happen to
Elisa after the fix?
--
You are receiving this mail because:
You are watching all bug changes.
Loading...