Discussion:
[plasmashell] [Bug 390177] New: Upgrade to 5.12 activated window decoration menu button, making in-app menu bars disappear
Add Reply
Nate Graham
2018-02-09 21:12:10 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

Bug ID: 390177
Summary: Upgrade to 5.12 activated window decoration menu
button, making in-app menu bars disappear
Product: plasmashell
Version: 5.12.0
Platform: Other
OS: Linux
Status: UNCONFIRMED
Severity: normal
Priority: NOR
Component: general
Assignee: ***@davidedmundson.co.uk
Reporter: ***@zoho.com
CC: plasma-***@kde.org
Target Milestone: 1.0

Just what the title says. I have now seen three unique reports of this issue,
all on different distros:

1. I experienced it myself (Kubuntu 17.10); see
https://phabricator.kde.org/T7905

2. https://www.reddit.com/r/kde/comments/7vpwb5/plasma_512_bug_thread/dtv3t4y/
(KD Neon)

3.
https://www.reddit.com/r/kde/comments/7wgdj7/all_the_menus_disappeared_after_the_512_update/
(Arch)
--
You are receiving this mail because:
You are watching all bug changes.
Nate Graham
2018-02-09 21:13:48 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

--- Comment #1 from Nate Graham <***@zoho.com> ---
Workaround: remove the Application Menu window decoration item.
--
You are receiving this mail because:
You are watching all bug changes.
b***@kde.org
2018-02-09 21:18:16 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

***@gmail.com changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |***@gmail.com

--- Comment #2 from ***@gmail.com ---
(In reply to Nate Graham from comment #1)
Post by Nate Graham
Workaround: remove the Application Menu window decoration item.
You mean the Application Menu button? Because removing it does not fix this for
me. Or maybe you need a logout?
--
You are receiving this mail because:
You are watching all bug changes.
Nate Graham
2018-02-09 21:22:20 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

--- Comment #3 from Nate Graham <***@zoho.com> ---
Yes, the Application Menu button. Once you remove it from your Window
Decorations, affected apps will need to be restarted, or you can reboot the
machine.
--
You are receiving this mail because:
You are watching all bug changes.
b***@kde.org
2018-02-09 21:27:09 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

--- Comment #4 from ***@gmail.com ---
(In reply to Nate Graham from comment #3)
Post by Nate Graham
Yes, the Application Menu button. Once you remove it from your Window
Decorations, affected apps will need to be restarted, or you can reboot the
machine.
Unfortunately they do not for me, even after a reboot. Arch, 5.12.
--
You are receiving this mail because:
You are watching all bug changes.
Nate Graham
2018-02-09 21:28:54 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

--- Comment #5 from Nate Graham <***@zoho.com> ---
OK, then you have a different issue, or there's some complicating factor at
play. Do you use KWin, or another window manager? Do your apps normally have
titlebars?
--
You are receiving this mail because:
You are watching all bug changes.
b***@kde.org
2018-02-09 21:31:01 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

--- Comment #6 from ***@gmail.com ---
(In reply to Nate Graham from comment #5)
Post by Nate Graham
OK, then you have a different issue, or there's some complicating factor at
play. Do you use KWin, or another window manager? Do your apps normally have
titlebars?
I do use KWin. I usually do not have titlebars: I have a window-specific
override (in Window decorations) to disable them. However of course I
re-enabled titlebars for this testing, and for now the only way I can have the
menus is to have the titlebars + the burger menu.
--
You are receiving this mail because:
You are watching all bug changes.
David Edmundson
2018-02-10 05:06:49 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

--- Comment #7 from David Edmundson <***@davidedmundson.co.uk> ---
Pre 5.12 appmenu was managed by 2 config keys on separate places, it was
possible to be in a corrupt state where a user had explicitly enabled in window
deco menus, but chose not to export menus.

In 5.12 it was consolidated into 1.

Any user with this had previously added the application menu to kwin at some
point, and now we've "fixed" it so it works.

Not really a bug, but maybe I can craft a kconf update script to remove the
button if it wasn't exported.
--
You are receiving this mail because:
You are watching all bug changes.
b***@kde.org
2018-02-10 09:21:25 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

--- Comment #8 from ***@gmail.com ---
(In reply to David Edmundson from comment #7)
Post by David Edmundson
Pre 5.12 appmenu was managed by 2 config keys on separate places, it was
possible to be in a corrupt state where a user had explicitly enabled in
window deco menus, but chose not to export menus.
In 5.12 it was consolidated into 1.
Any user with this had previously added the application menu to kwin at some
point, and now we've "fixed" it so it works.
Not really a bug, but maybe I can craft a kconf update script to remove the
button if it wasn't exported.
So basically this is a misconfigured config flag somewhere that has been
deprecated by the update, but before it sat there doing nothing and now it
breaks menus? Can you tell me where this could be, what to look for, so that I
can confirm (and fix)?
--
You are receiving this mail because:
You are watching all bug changes.
b***@kde.org
2018-02-10 11:03:28 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

--- Comment #9 from ***@gmail.com ---
Removing `~/.config/katerc` in `~/.config/katerc` fixed it... for those
programs, at least.
--
You are receiving this mail because:
You are watching all bug changes.
David Edmundson
2018-02-10 23:01:52 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177
Can you tell me where this could be, what to look for, so that I can confirm (and fix)
System settings -> application style -> window decorations -> buttons

If you don't want menus in the window titles, don't have the application menu
icon in your list of buttons.

Similar situation can happen with the global menu applet being placed on the
desktop.
--
You are receiving this mail because:
You are watching all bug changes.
b***@kde.org
2018-02-11 10:34:58 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

--- Comment #11 from ***@gmail.com ---
(In reply to David Edmundson from comment #10)
Post by David Edmundson
Can you tell me where this could be, what to look for, so that I can confirm (and fix)
System settings -> application style -> window decorations -> buttons
If you don't want menus in the window titles, don't have the application
menu icon in your list of buttons.
Similar situation can happen with the global menu applet being placed on the
desktop.
Unfortunately I do not have the menus even if I remove the burger menu from the
title bar. I had to manually modify katerc and okularrc to get menus back, as
per previous post.
--
You are receiving this mail because:
You are watching all bug changes.
Brecht Vercruyce
2018-02-12 22:15:02 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

Brecht Vercruyce <***@vercruyce.eu> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |***@vercruyce.eu

--- Comment #12 from Brecht Vercruyce <***@vercruyce.eu> ---
I have the same issue. I never used the global menu feature before. After the
update to 5.12 menu bars disappeared in several applications. It took me quite
a while to figure out what happened and eventually I ended up here.

Setting Show Menu Bar=true in for example ~/.config/katerc did not bring back
the menu bar. So far, I have found no way to bring the menu bar back, so I am
forced to use the "application menu" button on the title bar to have at least
some way of accessing the menu. I created a new account and with these clean
settings everything works.
--
You are receiving this mail because:
You are watching all bug changes.
b***@kde.org
2018-02-13 09:07:10 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

***@laposte.net changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |***@laposte.net

--- Comment #13 from ***@laposte.net ---
Same Here :(
Some users have no more menu bar after upgrading to 5.12.
Please, provide us a workaround (ie: editing the setting in the right config
file), I don't want delete my kde profile !
--
You are receiving this mail because:
You are watching all bug changes.
David Edmundson
2018-02-13 13:08:04 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

--- Comment #14 from David Edmundson <***@davidedmundson.co.uk> ---
Please include the output of:

qdbus org.kde.kappmenuview
--
You are receiving this mail because:
You are watching all bug changes.
Brecht Vercruyce
2018-02-13 13:14:05 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

--- Comment #15 from Brecht Vercruyce <***@vercruyce.eu> ---
$ qdbus org.kde.kappmenuview
/
/DataEngine
/DataEngine/applicationjobs
/DataEngine/applicationjobs/JobWatcher
/FileUndoManager
/MainApplication
/PlasmaShell
/Unity
/klipper
/org
/org/freedesktop
/org/freedesktop/Notifications
/org/kde
/org/kde/osdService
/org/kde/plasmashell
--
You are receiving this mail because:
You are watching all bug changes.
David Edmundson
2018-02-13 13:19:05 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

--- Comment #16 from David Edmundson <***@davidedmundson.co.uk> ---
So you have a global menu plasmoid somewhere

Next request: ~/.config/plasma-org.kde.plasma.desktop-appletsrc
also can I have a screenshot of your desktop please
--
You are receiving this mail because:
You are watching all bug changes.
Brecht Vercruyce
2018-02-13 13:35:02 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

--- Comment #17 from Brecht Vercruyce <***@vercruyce.eu> ---
The contents of plasma-org.kde.plasma.desktop-appletsrc:
https://gist.github.com/vercruyce/beefbe21464ae030512934f0a67f06c4
Screenshot of desktop: Loading Image...
--
You are receiving this mail because:
You are watching all bug changes.
David Edmundson
2018-02-13 14:24:29 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

--- Comment #18 from David Edmundson <***@davidedmundson.co.uk> ---
According to the config there are 3 panels

One (containment 93) has the appmenu in it - and we're clearly loading it as
it's registered the DBus iface.

Yet I can't see it in the screenshot.


Can I have your ~/.config/plasmashellrc too please
--
You are receiving this mail because:
You are watching all bug changes.
Brecht Vercruyce
2018-02-13 14:39:54 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

--- Comment #19 from Brecht Vercruyce <***@vercruyce.eu> ---
Well, I'm an idiot. There is indeed another panel that is not on the
screenshot. I have a second monitor attached which was not included in the
screenshot. And there was indeed a panel there, and that panel did indeed
contain a global menu widget. I completely mistook it for that button you click
to configure the panel (when the widgets are not locked). I'm sorry to have
troubled your with this, the feature does indeed work as intended, it was a
complete oversight by me.

In any case, thank you very much for your effort and time in helping me fix
this.
--
You are receiving this mail because:
You are watching all bug changes.
David Edmundson
2018-02-13 14:43:33 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

--- Comment #20 from David Edmundson <***@davidedmundson.co.uk> ---
no problem.

***@laposte.net

can you post the same information and we'll go through it with you too.
--
You are receiving this mail because:
You are watching all bug changes.
b***@kde.org
2018-02-13 17:42:31 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

--- Comment #21 from ***@laposte.net ---
I have been to see the user :
the issue was between the chair and the keyboard.
All is ok, sorry for the inconvenience.
many thanks for your work.
--
You are receiving this mail because:
You are watching all bug changes.
b***@kde.org
2018-02-18 21:26:59 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

***@kaosx.us changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |***@kaosx.us
--
You are receiving this mail because:
You are watching all bug changes.
David Edmundson
2018-02-18 21:31:01 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

David Edmundson <***@davidedmundson.co.uk> changed:

What |Removed |Added
----------------------------------------------------------------------------
Resolution|--- |INVALID
Status|UNCONFIRMED |RESOLVED

--- Comment #22 from David Edmundson <***@davidedmundson.co.uk> ---
cool, thanks all for reporting back.
--
You are receiving this mail because:
You are watching all bug changes.
Евгений
2018-03-01 19:56:15 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

Евгений <***@yandex.ru> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |***@yandex.ru
Version|5.12.0 |5.12.2
Status|RESOLVED |VERIFIED
Resolution|INVALID |WONTFIX

--- Comment #23 from Евгений <***@yandex.ru> ---
Hi,
same issue. Still no menu in Kate, Okteta, Okular etc. In attached screenshots
and configs you can see, that nowhere global menu or decoration menu button is
active.

plasmashell 5.12.2

screenshots:
https://ibb.co/gaSgxc
https://ibb.co/k3BVqx
https://ibb.co/hiMkOH

plasma-org.kde.plasma.desktop-appletsrc:
plasmashellrc:
https://pastebin.com/znH3BAZx
https://pastebin.com/L6ZsVCLZ

$ qdbus org.kde.kappmenuview

/
/0
/ColorCorrect
/ColorPicker
/Compositor
/Effects
/KWin
/Screenshot
/Scripting
--
You are receiving this mail because:
You are watching all bug changes.
Nate Graham
2018-03-01 19:58:31 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

--- Comment #24 from Nate Graham <***@kde.org> ---
Did you mean to mark this bug VERIFIED WONTFIX, or re-open it?
--
You are receiving this mail because:
You are watching all bug changes.
Евгений
2018-03-01 20:17:29 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

Евгений <***@yandex.ru> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|VERIFIED |REOPENED
Resolution|WONTFIX |---
Ever confirmed|0 |1

--- Comment #25 from Евгений <***@yandex.ru> ---
Re-open it, please. It's not fixed.
--
You are receiving this mail because:
You are watching all bug changes.
Nero
2018-03-25 17:01:23 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

Nero <***@gmail.com> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |***@gmail.com
--
You are receiving this mail because:
You are watching all bug changes.
Christoph Feck
2018-03-30 12:43:08 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

Christoph Feck <***@kde.org> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|REOPENED |NEEDSINFO
Resolution|--- |WAITINGFORINFO

--- Comment #26 from Christoph Feck <***@kde.org> ---
Please read the previous comments and provide the information needed to
investigate why it does not work on your system.
--
You are receiving this mail because:
You are watching all bug changes.
Christoph Feck
2018-03-30 12:44:22 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

Christoph Feck <***@kde.org> changed:

What |Removed |Added
----------------------------------------------------------------------------
Resolution|WAITINGFORINFO |---
Ever confirmed|1 |0
Status|NEEDSINFO |UNCONFIRMED

--- Comment #27 from Christoph Feck <***@kde.org> ---
Sorry, did not see comment #23.

David, does comment #23 help to pinpoint the issue for this user?
--
You are receiving this mail because:
You are watching all bug changes.
Francesco Riosa
2018-04-02 13:39:31 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

Francesco Riosa <vivo75+***@gmail.com> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |vivo75+***@gmail.com

--- Comment #28 from Francesco Riosa <vivo75+***@gmail.com> ---
Even after disabling the "Application Menu button" I had the menu explicitly
disabled in these apps:

$ cd ~/.config
$ grep -sl MenuBar=Disabled *
arkrc
dolphinrc
gwenviewrc
katerc
kmail2rc
komparerc
krdcrc
kritarc
kwriterc
okularrc
systemsettingsrc

If memory serves me well kate menu - was there after removing the button - but
NOT after rebooting the PC - most probably there was a kde update in the
meantime (5.12.3 => 5.12.4)
--
You are receiving this mail because:
You are watching all bug changes.
Francesco Riosa
2018-04-02 13:48:01 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

--- Comment #29 from Francesco Riosa <vivo75+***@gmail.com> ---
Created attachment 111784
--> https://bugs.kde.org/attachment.cgi?id=111784&action=edit
~/.config/plasma-org.kde.plasma.desktop-appletsrc

This is my "plasma-org.kde.plasma.desktop-appletsrc" the menu button is
currently disabled (it hide menus in libreoffice)
As described in previous comment menus were disabled after disabling the button
, and rebooting the PC
--
You are receiving this mail because:
You are watching all bug changes.
Francesco Riosa
2018-04-02 13:52:53 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

--- Comment #30 from Francesco Riosa <vivo75+***@gmail.com> ---
example of the content of the files after manually changing MenuBar=Disabled to
MenuBar=Enabled (and thus solving the problem)

$ grep MenuBar -B3 -A9 okularrc

[MainWindow]
Height 1440=889
MenuBar=Enabled
State=AAAA/wAAAAD9AAAAAAAABp4AAANTAAAABAAAAAQAAAAIAAAACPwAAAABAAAAAgAAAAEAAAAWAG0AYQBpAG4AVABvAG8AbABCAGEAcgEAAAAA/////wAAAAAAAAAA
ToolBarsMovable=Disabled
Width 2560=1694

[Print Preview]
Height 1440=500
Width 2560=600

[Recent Files]
--
You are receiving this mail because:
You are watching all bug changes.
Евгений
2018-04-02 17:00:30 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

--- Comment #31 from Евгений <***@yandex.ru> ---
I executed find ./ -type f -exec sed -i 's/MenuBar=Disabled/MenuBar=Enabled/g'
{} \; in .config folder, then was not changed anything: still there is not
menubar in applications.
--
You are receiving this mail because:
You are watching all bug changes.
Tom Kijas
2018-04-19 07:50:15 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

Tom Kijas <***@gmail.com> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |***@gmail.com
Ever confirmed|0 |1
Status|UNCONFIRMED |CONFIRMED

--- Comment #32 from Tom Kijas <***@gmail.com> ---
Same here, I will probably have to remove all kde configs and start from the
scratch. Shame!
--
You are receiving this mail because:
You are watching all bug changes.
David Edmundson
2018-04-19 10:54:19 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390177

David Edmundson <***@davidedmundson.co.uk> changed:

What |Removed |Added
----------------------------------------------------------------------------
Resolution|--- |WAITINGFORINFO
Status|CONFIRMED |NEEDSINFO

--- Comment #33 from David Edmundson <***@davidedmundson.co.uk> ---
@Tom then attach the two files requested earlier.
--
You are receiving this mail because:
You are watching all bug changes.
Loading...