Discussion:
[Discover] [Bug 390123] New: Discover 5.12 hangs a lot
Add Reply
Nate Graham
2018-02-09 03:24:15 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390123

Bug ID: 390123
Summary: Discover 5.12 hangs a lot
Product: Discover
Version: 5.12.0
Platform: Ubuntu Packages
OS: Linux
Status: UNCONFIRMED
Severity: grave
Priority: NOR
Component: discover
Assignee: ***@kde.org
Reporter: ***@zoho.com
Target Milestone: ---

I've experienced this hang on my production Kubuntu 17.10 machine a *lot*. Less
so on my Neon dev VM, but it happens there too. I see it most often when I
click on an app in the list. The delegate turns blue, and then Discover hangs
forever.

Here's a sample backtrace, in case it helps at all:

Thread 1 "plasma-discover" received signal SIGINT, Interrupt.
0x00007ffff338574d in poll () at ../sysdeps/unix/syscall-template.S:84
84 ../sysdeps/unix/syscall-template.S: No such file or directory.
(gdb) bt
#0 0x00007ffff338574d in poll () at ../sysdeps/unix/syscall-template.S:84
#1 0x00007fffee0ae38c in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2 0x00007fffee0ae49c in g_main_context_iteration () from
/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3 0x00007ffff3fb56cb in
QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4 0x00007ffff3f5de2a in
QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) ()
from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5 0x00007ffff3f66d64 in QCoreApplication::exec() ()
from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6 0x00000000004162a8 in main ()


Different issue, or a dupe of Bug 386992?
--
You are receiving this mail because:
You are watching all bug changes.
Nate Graham
2018-02-09 03:25:12 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390123

--- Comment #1 from Nate Graham <***@zoho.com> ---
I can reproduce this on demand by clicking on Digikam from the Featured page
while Discover is still loading.
--
You are receiving this mail because:
You are watching all bug changes.
Nate Graham
2018-02-10 20:28:33 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390123

Nate Graham <***@zoho.com> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |***@gmx.com

--- Comment #2 from Nate Graham <***@zoho.com> ---
*** Bug 390218 has been marked as a duplicate of this bug. ***
--
You are receiving this mail because:
You are watching all bug changes.
Nate Graham
2018-02-10 20:31:18 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390123

Nate Graham <***@zoho.com> changed:

What |Removed |Added
----------------------------------------------------------------------------
Severity|grave |critical
Summary|Discover 5.12 hangs a lot |Discover 5.12 hangs/freezes
| |a lot

--- Comment #3 from Nate Graham <***@zoho.com> ---
FWIW, this makes Discover almost unusable for me in 5.12 on Kubuntu. I can't
hardly go 30 seconds without a hang.
--
You are receiving this mail because:
You are watching all bug changes.
Aleix Pol
2018-02-12 17:04:57 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390123

Aleix Pol <***@kde.org> changed:

What |Removed |Added
----------------------------------------------------------------------------
Latest Commit| |https://commits.kde.org/dis
| |cover/a2d6e79586b8c73f2e2d6
| |bb1262d348eb53f4b52
Status|UNCONFIRMED |RESOLVED
Resolution|--- |FIXED

--- Comment #4 from Aleix Pol <***@kde.org> ---
Git commit a2d6e79586b8c73f2e2d6bb1262d348eb53f4b52 by Aleix Pol.
Committed on 12/02/2018 at 17:02.
Pushed by apol into branch 'Plasma/5.12'.

Fix freeze when showing the ApplicationPage

Change the strategy to show the screenshots. It sometimes would get the
ListView stuck. Use a Row + Repeater instead.
Also change the scrolling shadows approach because somehow it wouldn't work
with the Row {}

M +11 -11 discover/qml/ApplicationPage.qml
M +81 -69 discover/qml/ApplicationScreenshots.qml
M +1 -0 discover/resources.qrc

https://commits.kde.org/discover/a2d6e79586b8c73f2e2d6bb1262d348eb53f4b52
--
You are receiving this mail because:
You are watching all bug changes.
Nate Graham
2018-02-13 22:37:28 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390123

Nate Graham <***@zoho.com> changed:

What |Removed |Added
----------------------------------------------------------------------------
Version Fixed In| |KDE Plasma 5.12.1
--
You are receiving this mail because:
You are watching all bug changes.
Nate Graham
2018-02-13 22:37:40 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390123

Nate Graham <***@zoho.com> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |***@gmail.com

--- Comment #5 from Nate Graham <***@zoho.com> ---
*** Bug 390408 has been marked as a duplicate of this bug. ***
--
You are receiving this mail because:
You are watching all bug changes.
b***@kde.org
2018-02-18 11:25:43 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390123

***@posteo.net changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |***@posteo.net

--- Comment #6 from ***@posteo.net ---
Created attachment 110776
--> https://bugs.kde.org/attachment.cgi?id=110776&action=edit
Backtrace - Discove froze after launch

Discover still freezes a lot on my system using KDE Frameworks 5.43.0, Qt 5.9.3
on Neon 5.12.1, 64-bit Kernel 4.4.0-112

The freezes seem to happen the most frequently on a new user account I set up
(for bug triaging).

In case it helps, I'm attaching a gdb backtrace of one freeze. What I did to
make that freeze happen: I simply launched Discover from Kicker and it froze
instantly. I had logged in just 5 min ago.

The freezes are rarely reproducible with the same action. Once it froze after
clicking Settings, and once it froze when I searched for an app.
--
You are receiving this mail because:
You are watching all bug changes.
b***@kde.org
2018-02-18 12:05:21 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390123

--- Comment #7 from ***@posteo.net ---
Created attachment 110780
--> https://bugs.kde.org/attachment.cgi?id=110780&action=edit
Backtrace: Discover froze when searching for app

(Sorry, that previous backtrace was probably not complete. I'm new to this and
trying to learn).

Discover just crashed again. Attaching gdb backtrace (the full one now, I
hope).

What I did:
- Launched Discover
- Started typing for an app ('keepass')
- Hit Enter
- Window froze and Discover became unresponsive
--
You are receiving this mail because:
You are watching all bug changes.
Aleix Pol
2018-02-18 17:19:50 UTC
Reply
Permalink
Raw Message
https://bugs.kde.org/show_bug.cgi?id=390123

--- Comment #8 from Aleix Pol <***@kde.org> ---
Make sure you have the latest stable PackageKit Qt.
--
You are receiving this mail because:
You are watching all bug changes.
Loading...